IRSSI-SA-2017-10 Irssi Security Advisory [1]

CVE-2017-15228, CVE-2017-15227, CVE-2017-15721, CVE-2017-15723, CVE-2017-15722

Description

Multiple vulnerabilities have been located in Irssi.

  1. When installing themes with unterminated colour formatting sequences, Irssi may access data beyond the end of the string. (CWE-126) Found by Hanno Böck.

    CVE-2017-15228 [2] was assigned to this issue.

  2. While waiting for the channel synchronisation, Irssi may incorrectly fail to remove destroyed channels from the query list, resulting in use after free conditions when updating the state later on. Found by Joseph Bisch. (CWE-416 caused by CWE-672)

    CVE-2017-15227 [3] was assigned to this issue.

  3. Certain incorrectly formatted DCC CTCP messages could cause NULL pointer dereference. Found by Joseph Bisch. This is a separate, but similar issue to CVE-2017-9468. (CWE-690)

    CVE-2017-15721 [4] was assigned to this issue.

  4. Overlong nicks or targets may result in a NULL pointer dereference while splitting the message found by Joseph Bisch.

    CVE-2017-15723 [5] was assigned to this issue.

  5. In certain cases Irssi may fail to verify that a Safe channel ID is long enough, causing reads beyond the end of the string. Found by Joseph Bisch. (CWE-126)

    CVE-2017-15722 [6] was assigned to this issue.

Impact

  1. May result in denial of service (remote crash).

  2. May result in denial of service (remote crash).

  3. May result in denial of service (remote crash).

  4. May result in denial of service (remote crash).

  5. May affect the stability of Irssi.

Affected versions

  1. All Irssi versions that we observed

  2. All Irssi versions that we observed

  3. All Irssi versions that we observed

  4. Irssi 0.8.17 and later

  5. All Irssi versions that we observed

Fixed in

Irssi 1.0.5

Upgrade to Irssi 1.0.5. Irssi 1.0.5 is a maintenance release in the 1.0 series, without any new features.

After installing the updated packages, one can issue the /upgrade command to load the new binary. TLS connections will require /reconnect.

Mitigating facts

  1. requires user to install malicious or broken theme file

  2. requires a broken ircd or control over the ircd

  3. requires a broken ircd or control over the ircd

  4. irc servers typically have length limits in place

  5. requires a broken ircd or control over the ircd

Patch

irssi/[email protected]43e44d553...

References