Irssi 0.8.20 Released

Posted on September 21st 2016

Irssi 0.8.20 has been released. This release fixes two remote crash issues in Irssi 0.8.17 and later. There are no new features. All users should upgrade to this version. See the NEWS for details.

Read the security advisory.

This release can be downloaded from our releases page. Binary test packages for various Linux distributions are automatically generated by the openSUSE Build Service and are available for download in the irssi-test repository.

Please check with your distro whether they provide officially updated packages. This is a possibly incomplete list of distros which have applied the hotfix to their stable versions instead of updating to 0.8.20:

  • Ubuntu 16.04 LTS (xenial): 0.8.19-1ubuntu1.2 (USN-3086-1)
  • Debian 8 (jessie): 0.8.17-1+deb8u1 (DSA 3672-1)

Note that the version shown by irssi internally is kept the same, but they are safe to use anyway. The installed version can be verified with dpkg -l irssi in ubuntu and debian.

Those who cannot upgrade right now, but with Perl support enabled in their Irssi, can load this script and add it to ~/.irssi/scripts/autorun as a first aid to mitigating these issues.


Furthermore, we are always looking for testers of the development version. Binaries of the current git development version are automatically packaged in the irssi-git repository. The current development source code can be downloaded from GitHub. Some more information on the Contributing page. Report Issues and do not hesitate to send in Patches!

Remember to follow Irssi on Twitter, discuss this news on reddit or pop into #irssi on Freenode.

The Irssi Team.